MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005014vera[All Projects] Issuespublic2016-07-26 05:422016-07-26 06:12
Reporterhyzteric 
Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
StatusnewResolutionopen 
PlatformOSOS Version
Summary0005014: The 'Test Luup code' sent gets mixed up with old code
DescriptionI'm debugging some stuff and I see that the code I paste in the textarea of the page "Test Luup code (Lua)" is not exactly what is sent to the vera.
If I go to /cgi-bin/cmh/log.sh?Device=LuaUPnP, I sometimes see my code all in red with errors. But when I check the code, it seems that it is mixed up with a previous (not necessarily the last one) code I tried!
Steps To ReproduceGo to "Test Luup code (Lua)"
Enter some code and click go
Open the log view "/cgi-bin/cmh/log.sh?Device=LuaUPnP"
Check the code that was executed
Enter some OTHER code and click go
Check the code that was executed in the log view
Continue until you see a JobHandler_LuaUPnP::RunLua failed, then your code is probably mixed up with old code.
Additional InformationSee screenshot
TagsNo tags attached.
Attached Filespng file icon testLuupCodeBug.png [^] (66,927 bytes) 2016-07-26 05:42

- Relationships

-  Notes
(0005931)
hyzteric (reporter)
2016-07-26 06:12

I found out that if I add a large amount of blank (spaces or line returns) at the end of my code, then I can make it work, the blanks overwrite the old mixed up stuff!

- Issue History
Date Modified Username Field Change
2016-07-26 05:42 hyzteric New Issue
2016-07-26 05:42 hyzteric File Added: testLuupCodeBug.png
2016-07-26 06:12 hyzteric Note Added: 0005931
2016-12-03 06:42 ddavis824 Issue cloned: 0005016


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker